5 Q&A

Q&A

キーワード検索:「タイトルのみ」と「本文を含む」検索ができます。
「本文を含む」検索で複数検索される場合は、間は半角スペースを使用してください。
例)テスト カバレッジ

絞り込み: 「製品」「カテゴリー」「タグ」の項目でチェックをつけ、「絞り込む」ボタンをクリックすると絞り込みが可能です。
絞り込みは「AND」または「OR」が使用可能です。

製品








カテゴリー




タグ
















5 Q&A

Q&A

キーワード検索:「タイトルのみ」と「本文を含む」検索ができます。
「本文を含む」検索で複数検索される場合は、間は半角スペースを使用してください。
例)テスト カバレッジ

絞り込み: 「製品」「カテゴリー」「タグ」の項目でチェックをつけ、「絞り込む」ボタンをクリックすると絞り込みが可能です。
絞り込みは「AND」または「OR」が使用可能です。

51 - 60 / 107

タイトル最終更新日製品カテゴリータグ
コード修正前のカバレッジテストの結果を引き継ぐ。 2025-04-08 DT+Trace, DT+FS, DT10, DT-Win

プロジェクトに含まれるソースコードが変更された場合、変更後に合わせたプロファイルが新たに作成されます。 最新のプロファイルに対して、コード変更前にテストしたカバレッジ結果(過去のプロファイル)を引き継ぐことで、コード変更で影響のあるテストのみを実施すれば、過去のテスト結果も含めて、最新のプロファイルでカバレッジを確認できます。 プロファイル間のカバレッジ情報の引き継ぎ手順 メニューから[ツール]→[環境設定]を選択します。      [環境設定]ダイアログの[解析]ページから、[カバレッジ情報のプロファイル自動引き継ぎ]を有効にします。 メニューから[解析]→[レポートデータの解析]を行うと、プロファイルにカバレッジテストの状態が記録されます。 この状...

続きを読む
Linux機器へのドライバ登録 2022-08-01 DT+Trace ,

この項目では、Linux環境におけるDT+Traceドライバの環境への実装の手順を解説しております。 実際導入を行う際には、ターゲット環境に合わせてDT+Traceの導入を行ってください。 また、データ取得には別途サンプルドライバのカスタマイズが必要となります。 各接続方式のチュートリアルも合わせてご覧ください。 ユーザーランド領域での実装 ユーザーランドのターゲットにDT+Traceのサンプルドライバを登録いただく場合は、 ターゲットのMakefileにサンプルドライバ等を追加してください。 ■Makefileの例 OBJECTS = target.o dt_xxx_drv.o (※”xxx”の部分は各接続方式になります。) HEADERS = *....

続きを読む
周期時間測定箇所を自分で設定したい 2022-06-27 DT+Trace ,,

本稿では、任意のテストポイントの周期時間を計測する方法を説明します。通常、初期状態でレポートを取得し解析を行うと「周期時間レポート」として、関数の入口(FuncIn種別)のテストポイントに着目したレポートが解析されます。そのため、タスクとして無限ループが実行されている場合などでは、関数の入口のテストポイントは最初の1回のみ実行されるので、周期時間レポートでは解析できません。タスクの周期を確認したりする場合に便利な設定です。 概要および手順 DT+Traceには「ステップ周期時間レポート」という解析機能があり、こちらを使用することで、任意のステップ(テストポイント)の周期時間をレポートとして確認可能です。大まかなフローは以下の通りです。 今回は「タスクと...

続きを読む
スレッドを使用して定周期でデータ出力をするファイル書き出しドライバ 2022-04-07 DT+Trace ,

課題 ファイル書き出し方式において、オーバーヘッドをより小さくして使用したい タクトタイムがシビアな処理の経路解析と実行時間の測定を行いたい。 解決方法 バッファに経路情報と通過時間を蓄積し、後から出力するドライバを使用します。 標準のサンプルドライバでは、テストポイントを通過する度にデータファイルに出力しますが、 ドライバ内でメモリバッファを確保して、テストポイントの処理実行時にはバッファにデータ記録のみを行います。 蓄積されたデータを定周期で実行されるスレッドを使用してファイルに書き込むことで、 標準のサンプルドライバよりも、オーバーヘッドを減らすことができます。 効果 テストポイント処理の時は、メモリバッファへのデータ記録のみをするので、 テスト...

続きを読む
C0カバレッジの計測で、テストレポートのサイズを小さくする。 2022-02-18 DT+Trace, DT10, DT-Win ,

ターゲットプログラムやテスト内容によっては、テストレポートの量が膨大になりがちです。保存先のストレージ容量に余裕が無く多量のデータが取得できなかったり、レポートデータのコピーに時間が掛かったりと、非効率なことが発生します。一度通過したテストポイントのレポートデータを収集しないことで、データサイズを抑えることができます。手順は以下の通りです。 メニューの[テスト実行]→[実行]を選択します。 [プログラムの実行]ダイアログから[ワンタイムトレース]を有効にします。 レポートデータを取得すると、一度通過したテストポイントのデータは収集されなくなります。...

続きを読む
レポート取得中に不具合が発生したタイミングを記録する。 2025-04-08 DT+Trace, DT+FS, DT10, DT-Win

レポート取得中に不具合が発生した場合、ブックマーク機能を使いテストレポート上に目印となるコメント(ブックマーク)を記録できます。記録されたブックマークをもとに、該当箇所へのジャンプやブックマーク位置からの解析など、不具合が発生したタイミングのレポートを特定・解析する手掛かりになります。 ブックマークの設定 レポート取得中に表示される[テストレポート取得中]ダイアログの[ブックマーク]の項目から、コメントを入力し、[タイプ1~3 セット]ボタンのいずれかを押します。 取得中のレポートに、設定したブックマークが記録されます。 レポート取得終了後に表示される[マークビュー]の項目をダブルクリックすると、ブックマーク位置にジャンプします。...

続きを読む
特定のプリプロセッサをテストポイント自動挿入の対象から除外する。 2022-02-28 DT+Trace, DT10, DT-Win

テストポイント自動挿入の解析に失敗する場合(コメント領域以外でマルチバイトコードが出現する場合など)やデバッグコードなど、テストポイント自動挿入の対象から除外したい区間が存在する場合があります。 しかし、通常の自動挿入では、ヘッダファイルを認識しないため、プリプロセッサ処理で無効になっている箇所に対しても、テストポイントを挿入します。 プリプロセッサを考慮した上で、テストポイントを挿入するには、次の2つの方法があります。 条件付きコンパイル解析を用いる方法 条件付きコンパイル解析を行うには、プロジェクトに登録されているソースファイルがIncludeしているパスを、プロジェクトに設定する必要があります。 メニューから[ファイル]→[プロジェクト設定]を選...

続きを読む
DBOX+CameraとPCを有線LANで直結して使用する方法 2023-07-06 DT+Camera

DT+Cameraを使用する際は、DBOX+CameraにIPアドレスが割り当てられている必要があります。 IPアドレスが割り振られるためには、例えば社内のDHCPサーバと同一ネットワークに接続しなくてはならず、 企業によってはセキュリティ上の都合から接続できない場合もございます。 そこで社内のDHCPサーバに接続せず、PCとDBOX+Cameraを有線LANで直結して使用する方法について説明します。概要および手順 DT+CameraアプリケーションがインストールされているマシンにDHCPサーバを構築します。 手順は以下のようになります。 ”Open DHCP Server” をインストール PCの有線LANアダプタのIPアドレスを固定する ”Open...

続きを読む
DT+TraceとDT+Analogを同時にデータ取得したい 2022-06-29 DT+Trace, DT+Analog, DBOX+Trace ,

起動している別のDT+TraceやDT+Analogのテストレポート取得の開始/停止を同期することができます。   事前にDBOX+Trace/DBOX+Analogが接続済みとなっているかご確認ください。 同期して取得開始/終了の操作はDT+Traceでのみ行います。 DT+Traceアプリの左側の[実行]アイコンをクリックします。 [取得開始]の[▼]ボタンをクリックし、[DT+と同期して取得開始]を選択します。 [DT+と同期して取得開始]をクリックして、データを取得します。   注意事項 接続方式が[ファイル書き出し]のプロジェクトでは使用できません。 バッファフルが発生による取得停止または、その他の異常停止が起きた場合、テ...

続きを読む
規定外の処理時間による不具合のレポートを特定する。 2025-04-08 DT+Trace, DT+FS, DT10, DT-Win ,

描画や音声が途切れたり、あるタイミングで操作を受け付けないような不具合の場合、実行時間や周期時間が想定内の処理時間に収まっていないといった原因が考えられます。こういったタイミング依存の不具合であれば、実行時間や周期時間レポートから問題箇所を検出できます。 最大となる処理時間のレポートを表示させる メニューから[レポート解析]→[レポートの解析]を選択します。 [実行時間レポート]や[周期時間レポート]の最大時間及び平均時間に着目し、処理時間が極端に長い関数をダブルクリックします。 [実行/周期時間詳細リスト]上で右クリックから[最大値]を選択します。 関数の実行/周期時間が最大となった処理のレポートが緑色で表示されます。...

続きを読む